Ir al contenido principal

AppLocker en Windows 7

AppLocker es una de las nuevas funcionalidades que incorpora tanto Windows 7 como Windows Server 2008 R2, y que remplaza las antiguas directivas de restricción de software. Esta herramienta facilita la administración del sistema y permite a los administradores establecer determinadas reglas.
Para comenzar a trabajar con AppLocker es necesario ejecutar Panel de control, Herramientas Administrativas, Políticas de Seguridad Local, Políticas de Control de Aplicaciones, AppLocker. o también podemos ir al "menú inicio" y escribimos "Directiva"


Allí vemos las políticas que AppLocker crea por defecto al usar la herramienta por primera vez, para crear una nueva regla solo damos clic derecho sobre el área y "Crear Nueva Regla"


















Se nos Abre el asistente para Creación de Nueva Regla y se nos muestra una breve introducción sobre AppLocker.


Lo siguiente es definir que tipo de regla vamos a crear "Permitir/Denegar" y también escogeremos al grupo de Usuarios que se le va aplicar la directiva local. en este caso para la Demo escogeremos "Denegar"

Luego se nos permite aplicarle tres tipos de condiciones a la regla "Editor, Ruta de Acceso, y Hash de Archivo" lo cual describo cada una de ellas

Editor: Selecciones esta opción si la aplicación para la que desea aplicar esta regla está firmada por el editor de Software.

Ruta de Acceso: Crea reglas en un determinado archivo o directorio. Si se aplica esta regla sobre un directorio todos los archivos y subcarpetas que contenga se verán afectados por la misma regla.

Hash de Archivo: Esta opción es adecuada cuando la aplicación no está firmada y no contiene atributos de publicación, por lo que la regla se aplicará sobre el hash del archivo.


Para ocasión de esta Demo escogemos la opción "Ruta de Archivo" en donde buscaremos la ruta donde se encuentra el archivo .exe de la aplicación a "Denegar" su ejecución ejemplo: Messenger


una vez configurada la regla que permita o deniegue la ejecución, es posible aplicar excepciones basadas en las 3 condiciones anteriores: Editor, Ruta de Archivo y Hash.



Definimos el nombre para la política Local y su descripción


Por ultimo veremos la política local creada


Espero lo puedan aplicar. Muchas Gracias

Comentarios

Entradas populares de este blog

Error 1355 El dominio especificado no existe o no se pudo poner en contacto con él. [La Solución]

Actualización Hola a todos, quiero compartir este error que me ha sucedido después de realizar una recuperación del System state de un Domain Controller que tengo en mi ambiente de pruebas, el proceso se realizó satisfactoriamente, pero al momento que ingreso al Server Manager y comienzo a chequear todos los roles y características de mi DC ohh!!! sorpresa que me llevo, al tratar de ingresar a Usuarios y equipos de Active Directory me encuentro con este error, error que en un ambiente de pruebas no es muy preocupante pero en uno de producción sería fatal para nuestra organización. El error fue el siguiente Y no se encuentra nada de las OUs o carpetas predeterminadas por ADDS, que es lo mas preocupante   Entonces comencé a buscar cual sería la causa, y por la primera parte en donde debemos buscar un error en nuestro servidor es el visor de sucesos, el cual comprende a los servicios de Active directory y me he encontrado el siguiente error. ...

Crear VPN Point-to-Site en Microsoft Azure

  ¿Que pasa cuando queremos conectar nuestros equipos locales con las maquinas virtuales en Azure? R:/ Tenemos que configurar una red VPN para conectar estos equipos sea de punto a sitio (Azure) o de sitio a sitio. De esta forma podemos conectar nuestros equipos a los servicios de Azure a través de un canal seguro por VPN el cual debemos crear en el portal de Azure y especificar la configuración de asignación de direcciones IP que entregará la VPN , debemos también crear unos certificados para asegurar la conexión en donde cargamos uno en Azure y otro lo instalamos en los equipos que se conectarán. Como les describo en el vídeo, la creación de los certificados la podemos ver en este vídeo el cual explico como generarlos con la herramienta MakeCert.exe y que viene en Windows SDK, también podemos descargar solo la herramienta MakeCert.exe sin tener que instalar el SDK y eso lo podemos ver en este vídeo . Espero que les sea de mucha ayuda este video, si tienen alguna pre...

Crear maquina virtual con SQL Server 2012 en Windows Azure

Microsoft Azure es una plataforma muy completa, tenemos el área de bases de datos pero también podemos crear maquinas virtuales con instancias de SQL Server 2012 ya instaladas y listas para utilizar. Es por esto que Microsoft Azure es una solución mucho mas completa y abierta para todas las posibilidades que sus rivales, les dejo el siguiente vídeo donde veremos el proceso completo para tener un SQL Server 2012 corriendo en una VM de Azure. Espero que les sea de mucha ayuda este video, si tienen alguna pregunta u opinión me la pueden dejar en mis redes sociales: Facebook , Twitter , Google+, recuerden suscribirse y compartir este y los demás videos de mi canal de YouTube . Muchas Gracias. Jair Gómez Arias Suscribirse → bit.ly/SuscribirseJGAITPro Facebook → bit.ly/JGAITProFB Twitter → bit.ly/JGAITProTW Google+ → bit.ly/JGAITProGP Blog → bit.ly/JGAITProBlog